Firefox 55 profilus nevar pazemināt

Ja esat jauninājis Firefox versiju uz 55 vai jaunāku versiju, vēlāk nevarēsit pazemināt šo pārlūka versiju uz vecāku versiju.

Kaut arī Mozilla nekad agrāk īsti neatbalstīja pārlūkprogrammas pazemināšanu, parasti nebija problēmu pazemināt noteiktu Firefox pārlūka versiju.

Pastāv divi galvenie lietošanas gadījumi, kad tas notiek: pirmkārt, kad problēmas rada Firefox izlaišanas versija un kad lietotāji izmanto to pašu profilu dažādās pārlūka versijās.

Pirmā problēma rodas, kad Firefox lietotājiem rodas problēmas pēc Firefox pārlūka atjaunināšanas. Pēc tam viņi var no jauna instalēt vecāku Firefox versiju. Tā kā Firefox automātiski uzņem noklusējuma profilu vai citu profilu, ja jūs tam norādāt, pārlūks to var automātiski izmantot.

Tas var radīt dažas problēmas saistībā ar profilu, jo jaunās pārlūkprogrammas versijās var tikt ieviestas jaunas funkcijas vai dažas mainītas. Efekts var būt pamanāms vecākai versijai, taču tas parasti neizraisa pārlūka pilnīgu darbību.

Otrā problēma rodas, ja izmantojat dažādas Firefox versijas, izmantojot to pašu profilu. Tas nav ieteicams, jo, iespējams, rodas vienas un tās pašas problēmas, kas aprakstītas iepriekš (pārslēdzoties starp dažādām laidiena versijām).

Kļūdu ziņojumā par uzsvērts, ka Firefox 55 vai jaunāka profila profili vairs nedarbosies vecākās pārlūka versijās.

Firefox 55 ir nākamā pārlūka versijas versija; Plānotais izlaišanas datums ir 2017. gada 8. augusts. Lai gan informācija pati par sevi ir noderīga, tā ir īpaši svarīga lietotājiem, kuri plāno pāriet uz Firefox 52.x ESR, kad Firefox 57 tiks izlaists novembrī, jo profils vairs nedarbosies. ja viņi vienā brīdī ir instalējuši Firefox 55, 56 vai 57.

Īsumā : ja vēlaties pārslēgties uz ESR, iespējams, ir piemērots laiks to darīt pirms Firefox 55 izlaišanas. Jūs varat arī izveidot Firefox profila dublējumu pirms jaunināšanas uz Firefox 55 un atjaunot to pēc tam, kad savā sistēmā esat instalējis Firefox ESR.

Mozilla atzīmē, ka organizācija mainīja Firefox 55 "pastāvīgas glabāšanas profilos diska formātu" un ka šīs izmaiņas ir iemesls, kāpēc pēc profila izmantošanas Firefox 55 nevar izmantot jaunāku Firefox versiju.

Kad profils ir izmantots pārlūkprogrammā Firefox 55 (vai jaunākā versijā), to nevajadzētu izmantot ar iepriekšējām Firefox versijām. Visi indeksētieDB, (DOM) kešatmiņas API, servisa darbinieki un asm.js kešatmiņa nedarbosies, radot mulsinošas kļūdas un izraisot Firefox un dažu vietņu daļu sabojāšanos. Profilu var atkal padarīt darbināmu vecākās Firefox versijās, izmantojot profila "atsvaidzināšanas" mehānismu.